Results 1 to 3 of 3

Thread: Engine Vibration

  1. #1
    Join Date
    Aug 2010
    Location
    Orange Ca
    Posts
    209

    Engine Vibration

    A strong vibration is felt around 1500 rpm and continues on with varying intensity throughout the rev range. Tested while sitting in park.

    It is not a misfire or a cylinder with low compression. Just replaced plugs, wires, cap and rotor and it passed CA emissions test and is running extremely clean. It feels like a rotational mass is out of balance. I've replaced the water pump and fan clutch recently. The balancer is still in its correct position. The vibration was present before those parts were replaced.

    It doesn't really ever go away when either cold or warm but is less noticeable when driving.

    It feels like an out of balance torque converter.

    Could it be motor mounts?

    Any advice would be appreciated.

    Vehicle is a 1995 SWB with the original 3.9. 160K miles.
    1995 RRC LWB - Avalon Blue
    2004 Disco 2 SE7 - Giverney Green
    1987 Porsche 944 Turbo - Nile Green metallic
    1999 Range Rover 4.6 HSE Callaway #102 Epsom Green

  2. #2
    Join Date
    Oct 2006
    Location
    Oak Park, CA
    Posts
    2,206
    Did you check the flywheel?
    <DCProven >
    <1977 Land Rover Santana, Series III, 2.25 Diesel>
    <1995 RRC, LWB, 4.2 V8>

    "Information is not knowledge,..." Frank Zappa

  3. #3
    Join Date
    Aug 2010
    Location
    Orange Ca
    Posts
    209
    Not yet. I figure, if the flywheel is broken I'd have other symptoms such as noise. It runs and drives excellent otherwise.
    1995 RRC LWB - Avalon Blue
    2004 Disco 2 SE7 - Giverney Green
    1987 Porsche 944 Turbo - Nile Green metallic
    1999 Range Rover 4.6 HSE Callaway #102 Epsom Green

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •