Results 1 to 3 of 3

Thread: 1995 RRC Wiper Motor Issue

  1. #1
    Join Date
    Jan 2008
    Location
    CA
    Posts
    885

    1995 RRC Wiper Motor Issue

    Hello Everyone,

    I just recently purchased a 1995 LWB and found this morning that the wipers have some issues....

    In intermittent mode, the wipers will stop in the middle of the windshield, however in the low or high setting, they work fine.

    I am trying to prevent throwing parts at the car and was hoping someone has dealt with a similar issue in the past.

    I searched google and couldn't quite find a response for someone with the same issue.

    I know that it is either a bad combo switch or a bad motor, but would prefer to replace only the bad part.


    Thanks for the help!


    Sent from my iPhone using Tapatalk
    1992 RRC
    - 4.6L V8
    - GDE Winch Bumper
    - LT230
    - 3" Rovertym springs
    - Kargomaster Roof Rack
    - 255/85-16 BFG M/T
    NCLR083

  2. #2
    Join Date
    Aug 2010
    Location
    Utah
    Posts
    2
    I haVe the exact same problem on my 2000 Disco II. I replaced the steering column wiper stalk which turned out to be a total PITA! Sadly, it didn't fix the problem. Some suggested it might be the motor, but that doesn't make sunset considering that the wipers work fine on low, med and high.


    Sent from my iPad using Tapatalk

  3. #3
    Join Date
    Jan 2008
    Location
    CA
    Posts
    885
    My issue kinda sorted itself out. The New RRC I bought had been parked for 13 years. After using the wipers several times, they have started working normally. My guess is that there was some sort of surface corrosion present in the combo switch.


    Sent from my iPhone using Tapatalk
    1992 RRC
    - 4.6L V8
    - GDE Winch Bumper
    - LT230
    - 3" Rovertym springs
    - Kargomaster Roof Rack
    - 255/85-16 BFG M/T
    NCLR083

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •