Results 1 to 5 of 5

Thread: Auto Zone Put In Wrong Size Battery,ALARM WENT OFF BY ITSELF,RANGIE WON'T TURNOVER.

  1. #1
    Join Date
    Feb 2015
    Location
    Atlanta G.A.
    Posts
    3

    Angry Auto Zone Put In Wrong Size Battery,ALARM WENT OFF BY ITSELF,RANGIE WON'T TURNOVER.

    Hello New to the Forum-

    My Alarm went off for no apparent reason. It kept making weird beep every time turning key to left or right to try to shut it off-Alarm kept going off...Even after engine immobilized. Looked inside red dash light was blinking really fast. I let the car sit overnight. In the morning tried key in driver door, open no alarm went off no problem. But upon trying to start vehicle first time no sound,now it will crank but not turn over. Battery died Tuesday needed a jump from neighbor. I drove to Auto zone,they tested battery and alternator and said battery was bad. Battery replaced with Duralast. No problems,tues,wed,thurs...alarm went off Friday NOW PROBLEMS. I never had a remote when brought from owner. Everything is working just won't turnover. I do have a feeling the door handle is a bit clicky and my door lock has been loose and hard to unlock sometimes after about 20 minutes. But all this non cranking has been SINCE COLD WEATHER AND ALARM WENT OFF. Thank You

    Also,
    Just paid for 600 for water pump,which still seems to have a drip coming from some where as i see small coolant loss in bottle and around top&radiator hose. And a new compressor 2100$So my money is low till i can get on the road to my house clients to train them.

    Oh,just learned today Auto Employee put in a 450 crank battery. I didn't notice it till a neighbor tried to jump me with his 1500 truck. Wow the battery i found was in mine was 900 cranking amps lol. How could Auto Zone tech over looked this without checking specs...Could this be the reason truck still will not turn over now that i have the correct battery installed?Any help before i have to make a trip to THE "STEALERSHIP"would be appreciated.

    Thanks


    Hope some one can help.
    AL

  2. #2
    Join Date
    Jan 2006
    Location
    Fremont, California, United States
    Posts
    2,953
    Welcome,

    Please post in correct section next time.

    You need to have correct battery CCA first of all, then all faults need to be cleared. Cheapo scanner does not clear all faults. Next, what year and model Range is it?

    If 2003 or later then I suggest replacing hood alarm switch, that's why its going off.

    Check back and let us know,
    Tony DII
    Tony - Cerrone's European LRRForums Store

    1999 Disco II - aka Black Cobra - Daily Driver
    2006 Range Rover HSE aka Wife's Rig

  3. #3
    Join Date
    Feb 2015
    Location
    Atlanta G.A.
    Posts
    3
    My apologies..I wasn't sure how to post. But thank you.

    Auto zone is trying to dodge fault on their mistake. The alarm has not gone off. But i don't have key fob to sync it. I never needed it till the battery was improperly replaced. Everything far as windows have reset but range still won't turn over. I am not sure if my actuator needs replaced or my door handle. For a month now its been hard sometimes having the lock to pop up. Sometimes taking 15 to 40 multiple turns to get it to pop. Lock portion feels real loose when key is inserted. I don't trust many of these SO CALLED RR SPECIALIST. Most of them just want your car to sit for a few days while they do diagnostics. They can tell you anything with that. You never end up just paying diagnostics! Seems like that's just to get you in...Last Diagnostic fee from AMERICAN SERVICE STATION cost me $660.00 and nothing was done! Not going through that ordeal again smh.

    If i knew would portion of door i need to replace that would help. Then i could see if that eka will clear it. It seems like its still stuck in passive immobilization...What do you think? Range is 2000 hse.

    Thanks for your timely response.

    AL

  4. #4
    Join Date
    Feb 2015
    Location
    Atlanta G.A.
    Posts
    3
    Update if anybody can help me with my situation. Lock smith determined its not the lock or key. I was gonna have a key cut&reprogrammed.
    Mechanic says;Doors unlock&lock,..Alarm can be set,but car still won't crank. Mechanic said code is 1673. Does it still think some one is trying to steal it? Mechanic said rpm is not registering. He thought it might be crank sensor but has ruled it out for now. Another mechanic,a friend recommended who works on Rovers,say's it is CAN mode. That the computers are not communicating with each other. He say's i need it re-flashed but he doesn't have the particular soft ware to do it. The Mechanic who has the car said his scanners won't let him communicate. But he is not charging me for 3 days because he said he really didn't do anything. I am gonna give him something for his tech's time. NOBODY WORKS FOR FREE! Any way,this place called[ROAD BRITANNIA] said they do have that software as they specialize in Rovers. He said price would be $115 us dollars. Do you think this is the issue?And does this price seem customary?

    Thanks again..Hope someone can help.

    AL

  5. #5
    Join Date
    Oct 2010
    Location
    Carson City, California, USA
    Posts
    12
    well, you can always ask for damage/rebates from Auto Zone. Anyways you said that they are the ones who installed.

    I once remember a year ago when my uncle bought a new tire rim from a certain auto parts warehouse online store, they even initiated they if we buy from them they will be the one replacing or isntalling the new products to our car.

    then after installing the new tire, when uncle tested the car, it broke down. I mean the tire suddenly rolled out from the car and caused damaged to my uncle's car. fortunately, he was driving not so fast so no major accident happened. but the company paid ALL the damages including giving my uncle new tires and 1 year service maintenance for FREE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •