Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Lamp Delay Relay Draining Battery?

  1. #11
    Join Date
    Oct 2007
    Location
    Kelseyville, Ca.
    Posts
    2,408
    Yeah, I never seem to get more than a gentle hint of a breeze out of the far left vent.
    '91 RRC-4.2, R380, LT230, GDE bumper with Smittybuilt 8K winch, Custom 3" lift, 33's, Equipe trailing arms, Rock Ware sliders, Custom diff guards, Maxyedor HD steering, TT/Detroit, Rovertracks axles
    '61 Series II 88"
    '95 D90
    '94 RRC County LWB

    "There are three kinds of men: The one that learns by reading, the few who learn by observation and the rest of them have to pee on the electric fence for themselves." -Will Rogers

  2. #12
    Join Date
    Jul 2010
    Location
    Central Coast, Calif.
    Posts
    175
    Update:

    I didn't ever really act on my original problem b/c the issue went away... For TWO years.

    Today, I go out to the garage and I see the dome light on, after sitting for a whole day. Just drove it 330 miles over the weekend and off-roaded a bit. So the dome light goes OFF when I OPEN the door. Check all the door switches, pull the under steering wheel cover, etc. Take out the "courtesy light relay" and the light stays on. So... I am in the market for a new one or the Bosch short-cut go-around: SPST 4-pin -- about 8 bucks. No delay, but should do the trick.

    --Paul
    Last edited by ccec; 10-04-2017 at 09:23 AM. Reason: More info.
    '93 LWB, one of many L-R's over the years (GDE bumper w/Warn 8k, Disco axles, RTE 2" springs, Viair)
    1964 88" Truck Cab -- Stolen, then re-appeared locally after 20 yrs
    1966 88" Station Wagon -- Sold
    1967 NADA 109" -- Sold (after I wedged a 300 CID Ford 6 into it)... Help locate! Green 1967 NADA 109
    1990 RRC -- caught fire while wife driving solo... Good times!

  3. #13
    Join Date
    Jul 2010
    Location
    Central Coast, Calif.
    Posts
    175
    More Update:

    The Napa 5-pin relay that I bought for around 20 bucks doesn't really do anything. At least it doesn't allow the lights to stay on. I am still running my original delay relay because it seems to be behaving normally for the moment.

    --Paul
    '93 LWB, one of many L-R's over the years (GDE bumper w/Warn 8k, Disco axles, RTE 2" springs, Viair)
    1964 88" Truck Cab -- Stolen, then re-appeared locally after 20 yrs
    1966 88" Station Wagon -- Sold
    1967 NADA 109" -- Sold (after I wedged a 300 CID Ford 6 into it)... Help locate! Green 1967 NADA 109
    1990 RRC -- caught fire while wife driving solo... Good times!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •