Results 1 to 8 of 8

Thread: Need some help here

  1. #1
    Join Date
    Dec 2011
    Location
    Lake elsinore CA
    Posts
    3

    Need some help here

    Hi i have had my land rover freelander 02 4wd v6 for a couple months now. bought it on craigslist.com and now im having problems starting the car. i turn the key and no engine crank just silence. i think its the starter but i have no idea were it is located. if some one could help with some pics or instructions would be most helpful

  2. #2
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    Welcome to the forums!

    I don't know much about the freelander... hopefully someone can help you out. Do you hear *any* kind of clicking or noise when you turn the key?
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  3. #3
    Join Date
    Dec 2011
    Location
    Lake elsinore CA
    Posts
    3
    Ya I opened the hood and had my sis turn the key. I can hear some clicking and other noises like the fan but not any noises from the engine. I managed to get it to start after an hour. But than once I turned it off it started to give me the same problem again.

  4. #4
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    When it did start, did it turn over quickly and start right up?
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  5. #5
    Join Date
    Dec 2011
    Location
    Lake elsinore CA
    Posts
    3
    Yes it did. Which I thought was kinda weird.

  6. #6
    Join Date
    Sep 2011
    Location
    Cali
    Posts
    124
    Loose ground or dead battery (maybe)

  7. #7
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    Your starter is going bad... that's pretty much the classic symptoms. If it was the battery or ground, when it finally did decide to catch it would be slow and groaning. Sounds like the solenoid inside the starter is going wonky on you. You turn the key, the low power signal to the starter gets there, but the big relay that connects the high amp power from the battery isn't doing it's job.

    The only way to tell for sure is to pull it and have it tested... or at least test for the start signal arriving successfully to the starter without it turning over.
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  8. #8
    Join Date
    Sep 2011
    Location
    NYC
    Posts
    9
    Yes it could be the starter... but to be on the more cautious side, I would get someone to pull the codes from the ecu. My gf just recently had this issue with her 03 freelander. It would randomly start.. but for the most part it wouldn't even crank. We had pulled the codes and the infamous P1472 popped up - Variable Intake System Short Circuit 1.

    Most sites you check out will tell you to replace the intake manifold. This is not necessary. There are 2 motors attached to the manifold which come off quite easily in fact and are fairly easy to fix/replace. If this turns out to be the case (and I hope it's not), shoot me a message and I can walk you through the steps.

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •