Results 1 to 3 of 3

Thread: Td5 Wire harness issue.

  1. #1
    Join Date
    Dec 2008
    Location
    Montego Bay, Jamaica
    Posts
    9

    Td5 Wire harness issue.

    My dealer has advised me that my 2002 Td5 has a problem with the main and fuel injector wire harness routing oil to the ECM/computer. They have told me this is a common Td5 problem and want to change both harnesses and the ECM/Computer at a considerable cost. I am skeptical. Has anyone any info. on such problems?

  2. #2
    Join Date
    Jul 2012
    Location
    Standerton South Africa.
    Posts
    1
    Hi, I have just joined the forum today and have the same issue, did you ever get a response to this question?

    Appologies for barging in like this but I am getting pretty frustrated with the response from some of the dealers here in S.A



    Sent from my GT-P1000 using Tapatalk 2

  3. #3
    Join Date
    Dec 2008
    Location
    Montego Bay, Jamaica
    Posts
    9
    Hi Adrian, Sorry that I am just getting back to you. I just now saw your thread. The dealer first changed the fuel injector harness and hit me for U.S. $1,200 the oil loss continued and he then wanted to change the main harness and the computer. For a further $4,000+. I was learning to distrust him by this time and simply added an oil saver product I got at Pepboys in the United States and I have had no further oil loss. The oil saver cost me about U.S.$4. I no longer go anywhere near to the dealer. Please let me know how things work out for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •