Results 1 to 7 of 7

Thread: Rover won't start

  1. #1
    Join Date
    Dec 2009
    Location
    Des Moines
    Posts
    14

    Rover won't start

    Got in the RR this morning and it wouldn't start turn the key and started turning over like it was going to start but didn't released the key and it kept going like it was trying to start. Any ideas?

  2. #2
    Join Date
    Mar 2010
    Location
    Rockwall,TX
    Posts
    65
    Check the basics, fuel...spark....fuses.

  3. #3
    Join Date
    Dec 2006
    Location
    In the shop, doing the Lord's work, one broken Rover at a time!
    Posts
    414
    Year? Miles?

    I've been seeing an awful lot of MkIIIs with dead fuel pumps. They are stupidly expensive and take forever to replace. Fortunately, the test port is easily accessible.
    Wrenchin' to Riches

    DBA P T Schram Rover Repair, Churubusco, IN USA

  4. #4
    Join Date
    Dec 2009
    Location
    Des Moines
    Posts
    14
    06 with about 72k

  5. #5
    Join Date
    Dec 2006
    Location
    In the shop, doing the Lord's work, one broken Rover at a time!
    Posts
    414
    Check fuel pressure.
    Wrenchin' to Riches

    DBA P T Schram Rover Repair, Churubusco, IN USA

  6. #6
    Join Date
    Dec 2009
    Location
    Des Moines
    Posts
    14
    got it figured out crank sensor was bad thanks for all the recommendations

  7. #7
    Join Date
    Dec 2006
    Location
    In the shop, doing the Lord's work, one broken Rover at a time!
    Posts
    414
    At least it's REALLY, REALLY easy to get to!
    Wrenchin' to Riches

    DBA P T Schram Rover Repair, Churubusco, IN USA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •