Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: LR3 sunroof not working..?

  1. #21
    Join Date
    Jan 2015
    Location
    United States
    Posts
    1
    Quote Originally Posted by navydevildoc View Post
    There is one other trick you can try, which is to try and force a sunroof position recalibration... start the truck, and hold the "close" button for at least 20 seconds. Do it for 40 to be sure. This might kick-start it into working again. Long shot, but you never know.
    Hey Doc, I know you wrote this almost four years ago but, this just saved me a ton of heartache. I had my headliner halfway out, cussing, pricing new sunroof motors and low and behold - your trick worked. Thank you, thank you, thank you.

  2. #22
    Join Date
    Apr 2008
    Location
    Samammish, WA
    Posts
    428
    For me...this trick hasn't worked so I am forced to open up the headliner. I think the ECU is fried or something....
    2006 LR3 HSE - Chawton White on Black, Cold weather pkg, Navi, HD pkg, 7-seater, DVD, G4 rack/ladder.
    Former: 1990 Range Rover Classic

  3. #23
    Join Date
    Feb 2015
    Location
    Minneapolis, Minnesota
    Posts
    1
    I just wanted to send a huge thank you to Doc for his tips, I tried the hold the close button with the engine running suggestion and it absolutely worked. You saved me time, money and a ton of hassle. Thanks again!

  4. #24
    Join Date
    Apr 2015
    Location
    Iceland
    Posts
    1

    Cool Genius!!!!

    Quote Originally Posted by navydevildoc View Post
    Bummer. It's actually a real simple system. The power goes from fuse 20 to the controller... it takes control cues from the switch and LIN bus, and operates the motor.

    If you try and operate it without the engine running but with the interior lights on, do the lights dim slightly when you press the buttons? That might indicate that it's trying to move and is jammed in some way, as the motor is drawing power that's dimming the lights.

    Other than that, you are going to need a Faultmate or T4/IDS to scan the LIN network for fault information.

    There is one other trick you can try, which is to try and force a sunroof position recalibration... start the truck, and hold the "close" button for at least 20 seconds. Do it for 40 to be sure. This might kick-start it into working again. Long shot, but you never know.

    OMG recalibration worked for me too!! I had accidentally tried to open it with ice covering it and it stopped working after that. Thank you thank you!!

  5. #25
    Join Date
    Mar 2011
    Location
    TX, US
    Posts
    204
    That's great-- remember if you think it is frozen, let the car run for a good while, the heat will begin melting the ice, and then you'll be set. Don't force it, the plastic mechanisms break.
    PM me for Diff Parts, fridges, hitches

  6. #26
    AMAZING!!! My sunroof was stuck for a few days and I had no idea why. Scheduled appt. to take it to Land Rover this weekend till i came across this form. Held down the close button with the engine running and tt worked exactly at the 20th second! =D

    This was for a 2010 RR sport supercharged...

    Quote Originally Posted by Txrova View Post
    Doc...
    you genius!!!! I shut off the vehicle, checked if the interior lights dimmed when I tried to open/close, no change in bright-dim of the lights..

    and as a last ditch effort, held the sunroof in a closed position after I started the vehicle back up.. and sure enough, it worked!!!!

    :lmao

    Thanks so much, I really am stretched for time during the week with work and it's hard for me to get into the dealership. Wow.. still amazed that friggin' worked!

    Thanks again!
    Last edited by Phillip Esho; 01-12-2017 at 02:38 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •