Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: LR3 sunroof not working..?

  1. #1
    Join Date
    Feb 2010
    Location
    Not on this site, TX
    Posts
    27

    LR3 sunroof not working..?

    Hi folks,
    Any clue as to why my sunroof no longer opens and closes?.. fuse?..motor?.. should I take it in under warranty or is a DIY possible?

    I recently ran into to the problem after working night shifts of ice that froze during last weeks big ice/snow storm.

    Thanks and happy trailing!

  2. #2
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    No bueno!

    Well, first thing to check is fuse 20P in the central junction box behind the lower glove compartment. If you don't know how to get the glove box released, open the box all the way, and then if you look at the two catches on the outside of either end you can squeeze the tops to release the box.

    Check the fuse... if it's not blown then it's time to go a little further in troubleshooting.

    Nothing else is wrong with the truck, correct?
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  3. #3
    Join Date
    Feb 2010
    Location
    Not on this site, TX
    Posts
    27
    Hey doc,
    Thanks for the speedy response...
    I'm at the jobsite right now so I'm going to check and see the fusebox.. I'm a little familiar with it after installing some driving lights a few months back, not much though..lol.

    As far as I can see, no other electronic issues other than one of my window up/down buttons has become slightly dislodged and I don't know if it needs to be fixed or replaced.. as it still is functional, just kind've a PITA to keep having to push it back down into place when rolling the front passenger window up.

    I'll check and see and wb to ya. Any chance you know which fuse number it is?

  4. #4
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    Fuse 20P.

    Edit: Window controls coming out, while annoying (and first I have heard of that on the LR3), doesn't have much to do with the sunroof on these trucks. The sunroof control computer (yeah, it has its own computer) is on the low-speed LIN network. The windows are on the medium speed CAN Bus.
    Last edited by navydevildoc; 02-09-2011 at 10:12 PM.
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  5. #5
    Join Date
    Feb 2010
    Location
    Not on this site, TX
    Posts
    27
    update #1..

    brr.. chilly outside. Checked the fuse 20...the blue 15 one, still good. Put it back in it's socket. When I do press the open/close button of the sunroof I have no movement either direction (open/close.)

    What do you think I should try next?

  6. #6
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    Bummer. It's actually a real simple system. The power goes from fuse 20 to the controller... it takes control cues from the switch and LIN bus, and operates the motor.

    If you try and operate it without the engine running but with the interior lights on, do the lights dim slightly when you press the buttons? That might indicate that it's trying to move and is jammed in some way, as the motor is drawing power that's dimming the lights.

    Other than that, you are going to need a Faultmate or T4/IDS to scan the LIN network for fault information.

    There is one other trick you can try, which is to try and force a sunroof position recalibration... start the truck, and hold the "close" button for at least 20 seconds. Do it for 40 to be sure. This might kick-start it into working again. Long shot, but you never know.
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  7. #7
    Join Date
    Feb 2010
    Location
    Not on this site, TX
    Posts
    27
    Doc...
    you genius!!!! I shut off the vehicle, checked if the interior lights dimmed when I tried to open/close, no change in bright-dim of the lights..

    and as a last ditch effort, held the sunroof in a closed position after I started the vehicle back up.. and sure enough, it worked!!!!

    :lmao

    Thanks so much, I really am stretched for time during the week with work and it's hard for me to get into the dealership. Wow.. still amazed that friggin' worked!

    Thanks again!

  8. #8
    Join Date
    Jan 2009
    Location
    San Diego
    Posts
    281
    Sweet!!! I would have never bet on that working... something to remember I guess!



    The Rover Gods have smiled upon you!
    Neill
    2005 LR3 HSE
    1984 D90 300Tdi
    1965 Series IIA 88"
    Come Join Us On An Adventure! Land Rover Club of San Diego

  9. #9
    Join Date
    Jul 2010
    Location
    Ripon, Ca. (That's not England chaps)
    Posts
    1,514
    Quote Originally Posted by navydevildoc View Post
    The Rover Gods have smiled upon you!

    Bill of Green Achers Farms
    Adventure for fellow Geeks! Geocaching
    Land Rover Repair Manual - Download Site
    1. 1996 Discovery I - Yet to be named
    2. 1998 Discovery I - "Kermit"
    3. 2000 Discovery II - Parts Donor


  10. #10
    Join Date
    Sep 2007
    Location
    Hacienda Heights, CA
    Posts
    432
    We've been kicking ass at this diagnostic stuff lately! Now time for more fun and less breaking...
    2006 LR3 SE7 Heavy-Duty Pkg & 285/60 Nitto Terra Grapplers
    2003 Discovery II SE w/RTE 2" & 265/75 BFG KM (RIP)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •