Results 1 to 5 of 5

Thread: discovery 2 trailer wiring question

  1. #1
    Join Date
    Sep 2006
    Location
    Long Beach, CA
    Posts
    350

    discovery 2 trailer wiring question

    hey guys, so i did some searching and found that the walmart kit 46155 works for the disco 2 so i got it for about $20 bucks. here is the write up i've been following
    http://www.discoweb.org/trailerwire/index.htm

    my question is i'm going to keep the land rover female end of the plug on and just splice into the wires like the write up does. the thing i dont get is that there are 3 wires left over and greg says to cut them and twist them together? any help please. thanks guys
    2003 Disco SE7, front quick disconnects, OME 779 & 763 lift springs, OME shocks N107's up front, Bilstein 7100 full body reservoir’s 10" for the rear, Hankook Mud Terrains LT265/75/16

  2. #2
    Join Date
    Sep 2006
    Location
    Long Beach, CA
    Posts
    350
    ok i got past it and the install went great, but one issue. i followed the instructions and the left signal works the right signal works but the light dons'nt go on unless i use the rear parking brake light button. so i can run with light but it wont change the pitch when i hit the brakes. i'm just useing the tester i dont have a trailer right now to test it on.
    2003 Disco SE7, front quick disconnects, OME 779 & 763 lift springs, OME shocks N107's up front, Bilstein 7100 full body reservoir’s 10" for the rear, Hankook Mud Terrains LT265/75/16

  3. #3
    Join Date
    Jan 2009
    Location
    SWFL
    Posts
    11
    are you still having issues with your wiring? I just did the same thing with my D2, and had the same problem with the tester. But when I hooked it up to an actual trailer, ... it worked just fine.

    I had a question about extra wires and the trailer light on the dash.... I'm curious if the factory wired hook up tells the truck there is a trailer hooked up and adjust the tranny or ecu ion some way to accomodate for the trailer? Any thoughts??

    thanks
    Me - 03 DII
    Wife - 02 Freelander

  4. #4
    Join Date
    Sep 2006
    Location
    Long Beach, CA
    Posts
    350
    i have not yet hooked it up to a trailer yet. but i'm glad to hear it works, i dont think it changed up anything though it would be nice.
    2003 Disco SE7, front quick disconnects, OME 779 & 763 lift springs, OME shocks N107's up front, Bilstein 7100 full body reservoir’s 10" for the rear, Hankook Mud Terrains LT265/75/16

  5. #5
    Join Date
    Sep 2006
    Location
    Long Beach, CA
    Posts
    350
    So i finally got to use a trailor the other weekend to take my car in for a new turbo. i used a full trailor and when gassing onto the fwy the trailor light came on but then went away. anyone knows why it goes on or off and any other info about it?
    thanks
    2003 Disco SE7, front quick disconnects, OME 779 & 763 lift springs, OME shocks N107's up front, Bilstein 7100 full body reservoir’s 10" for the rear, Hankook Mud Terrains LT265/75/16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •