• Recent Threads

    Brockflock

    1999 Disco I SD

    Thread Starter: Brockflock

    Won't start.Probably the starter, but I think I am done.
    List of things replaced since 2013:
    MAF
    Stepper Motor.
    Throttle Position

    Last Post By: dcproven Yesterday, 09:51 AM Go to last post
    llomo000

    High idle RPM

    Thread Starter: llomo000

    I have a 1999 d2 w/188...miles I have an issue that seems strange to me and I can't solve it. When I start my disco she runs at high idle. Like it is

    Last Post By: llomo000 09-23-2016, 05:30 PM Go to last post
    jhmover

    Nevada Trophy 10/13-15/2016

    Thread Starter: jhmover

    Posting for Mike Green at West Coast British. If you have questions please contact him. Info on flyer.

    Last Post By: jhmover 09-21-2016, 10:11 PM Go to last post
    Green Achers

    Read/Reset SRS on 1996 Discovery 1?

    Thread Starter: Green Achers

    I turned my SRS light on, by blowing it's fuse (in a stupid moment). I'd like to buy a OBD2 scanner that will read/reset it but can't find any (for less

    Last Post By: dcproven 09-22-2016, 12:59 PM Go to last post
    Brockflock

    Won't start

    Thread Starter: Brockflock

    Well, I get in, turn the key, and I hear the standard clicking of various electrical stuff in the passenger side footwell. But the starter doesn't seem

    Last Post By: Brockflock Today, 01:54 PM Go to last post
  • Calendar

    September   2016
    Su Mo Tu We Th Fr Sa
    1 2 3
    4 5 6 7 8 9 10
    11 12 13 14 15 16 17
    18 19 20 21 22 23 24
    25 26 27 28 29 30
  • Recent Forum Posts

    Brockflock

    Won't start

    That is the button mounted on the firewall in the engine compartment? Just have to push it, right?
    If so, then I have tried that.

    Brockflock Today, 01:54 PM Go to last post
    dcproven

    Won't start

    Immobilizer?

    dcproven Today, 09:36 AM Go to last post
    Brockflock

    Won't start

    Battery is a top of the line. Only 2 years old. Never had any sluggish start. I got to work one day, everything fine, and when I went to leave, NADA!

    Brockflock Today, 09:30 AM Go to last post
    jagfixer

    Won't start

    Make sure battery is charged. Do a load test on battery. Check an see if charged voltage is 12.75volts or higher. If you get vehicle running, check

    jagfixer Today, 07:44 AM Go to last post
    taemian

    Thanks!

    Ended up getting the Wrangler Adventurer (Silent Armor replacement) "Go with what you know", so I did.

    taemian Yesterday, 10:37 PM Go to last post
    bbyer

    never could figure X gauge out

    Transmission temperature seems to be not possible to find.

    This seems odd as all diesel pickups have transmission temperature readouts,

    bbyer Yesterday, 05:52 PM Go to last post